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Warranty and Service Policy

Product Warranty

DATAQ Instruments, Inc. warrants that this hardware will be free from defects in materials and workmanship under
normal use and service for a period of 1 year from the date of shipment. DATAQ Instruments' obligations under this
warranty shall not arise until the defective material is shipped freight prepaid to DATAQ Instruments. The only
responsibility of DATAQ Instruments under this warranty is to repair or replace, at its discretion and on a free of
charge basis, the defective material.

This warranty does not extend to products that have been repaired or altered by persons other than DATAQ Instru-
ments employees, or products that have been subjected to misuse, neglect, improper installation, or accident.

DATAQ Instruments shall have no liability for incidental or consequential damages of any kind arising out of the
sale, installation, or use of its products.

Service Policy

1. All products returned to DATAQ Instruments for service, regardless of warranty status, must be on a freight-pre-
paid basis.

2. DATAQ Instruments will repair or replace any defective product within 5 days of its receipt.

3. For in-warranty repairs, DATAQ Instruments will return repaired items to the buyer freight prepaid. Out of war-
ranty repairs will be returned with freight prepaid and added to the service invoice.
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1. Introduction

This manual contains information designed to familiarize you with the features and functions of the DI-2108-P USB
data acquisition system.

Features

The DI-2108-P data acquisition instrument is a portable data recording module that communicates through your com-
puter's USB port. Power is derived from the interface port so no external power is required. Features include:

» 8 fixed differential analog inputs protected to £150V (transient).

*  Free WinDagq/Lite data acquisition recording software. Records up to four channels of data. Purchase an unlock
code to record more than four channels.

» 7 digital ports protected to +25V.

*  16-bit measurement resolution

*  Programmable measurement ranges of £2.5, £5, £10, 0-5, and 0-10 Volts.
*  Up to 160 kHz maximum throughput sampling rate.

* A push-button to tag remote events in WINDAQ software.

* LED indication for easy notification of device status.

*  Counter channel for counter/timer applications up to 65,536 points.

*  Frequency/Rate channel measuring 10Hz to 50kHz.

¢ ChannelStretch™ Technology allows you to sync up to 16 units with a total throughput of 480kHz or more
(requires unlock code for each device).

* Included .Net Class supports programming the DI-2108-P under any .Net programming language.*
*  Fully documented instrument protocol for programming the device in operating systems other than Windows.*

*ChannelStretch requires that each device be unlocked when used with WinDaq software. WinDaq unlock is not
required for ChannelStretch if programming devices yourself using the .Net class or instrument protocol.

Analog Inputs

The DI-2108-P features eight differential channel inputs located on a single sixteen-position screw terminal block for
easy connection and operation. Measurement ranges of £2.5, £5, £10, 0-5, or 0-10 Volts are programmable on a per
channel basis. Analog channels are protected to £150 V dc or peak ac.

Utilize the functionality of WINDAQ software to experience all the features encased in these small, inexpensive
instruments. Unlock code required to record more than four channels of any type.

Digital I/O

The DI-2108-P contains seven digital ports, that may be used individually as a general-purpose digital input or for a
specific function as designated on the device. Digital port DO may be used for WinDaq Events; Digital port D1 may
be used for WinDaq remote Start/Stop; Digital port D2 may be used for rate measurements; Digital port D3 may be

used for counts; Digital ports D4-D6 are general purpose digital input port. Please Note: Digital outputs are not sup-
ported in WinDaq software. Each port may be configured as a switch using third-party software.

Introduction
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Software

All software required to record and playback waveforms is included with the purchase of any DI-2108-P data acqui-
sition system.

WinDaq Dashboard

The WinDaq Dashboard utility allows you to start WinDaq software, configure and start stand-alone data logging,
and set the instrument clock to your PC. Units available for synchronized recording using ChannelStretch™ are
shown in compatible blocks of devices.

WinDAQ® Recording and Playback Software

WINDAQ Acquisition and WINDAQ Waveform Browser allow you to record and playback data acquired through your
instrument. WINDAQ software is an invaluable resource to record and analyze your data and is available for free from
our web site (www.dataq.com).

WINDAQ Lite Data Acquisition software (free) can be used to record waveforms directly and continuously to disk
while monitoring a real time display of the waveforms on-screen. It operates, displays, and records up to four chan-
nels in real time. An optional unlock code is available to record the rest of the channels on the device or to allow you
to sync multiple units.

WINDAQ Waveform Browser playback software (also known as “WWB?”) offers an easy way to review and analyze
acquired waveforms. A built-in data file translator allows the user to display multiple waveforms acquired by
WINDAQ Acquisition software or any of a wide range of data acquisition packages. The software’s disk-streaming
design allows data files of any length to be graphically displayed rapidly, in normal or reverse time directions. Seven
standard cursor-based measurements, frequency domain, and statistical analysis functions help simplify waveform
analysis and interpretation. WINDAQ Waveform Browser is free and installed when installing WINDAQ Software.

Help

All WINDAQ software utilizes context-sensitive help. Help may be accessed through the Help menu or by pressing the
F1 key with any pull-down menu item selected. This will take you directly to the Help topic most relevant to that par-
ticular function or feature. Help topics discuss in detail each function available in the software.

Introduction
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2. Specifications

Analog Inputs

Number of Channels:

Channel Configuration:

Measurement range per channel:

Input impedance:

DC accuracy:

Absolute maximum input without damage:
Common mode range:

Common mode rejection ratio:
dc to 60 Hz 0Q unbalanced

Channel-to-channel crosstalk rejection:

Digital Ports

Number of Ports:

Type:

Configuration:

Pull-up value:

Input high voltage threshold:
Input low voltage threshold:

Absolute maximum applied voltage (V):

Reserved Digital Inputs
Port 1:
Port 2:
Port 3:
Port 4:

ADC Characteristics

Resolution:

Resolution applied to measurements:
Max. sample throughput rate:

Min. sample throughput rate:

Sample rate timing accuracy:

8

Differential

Programmable £2.5, £5, £10, 0-5, 0-10 Volts

800 kQ differential

+0.05% of range 25°C, excluding common mode error
+150 V dc or peak ac (normal mode + common mode)
+228 V dc or peak ac

90 dB typical

110 dB typical

7

MOSFET switch

Programmable as digital input or switch
4.7 kQ

2.4V

0.8V

0<sV<25V

WINDAQ remote events
WINDAQ remote start/stop
Rate input

Count input

16-bit

>15.6-bit

160 kHz throughput

Hardware: 1.831 kHz with WinDaq software: 0.305 Hz
100 ppm (typical over 24 hours)

Digital Ports Programmed as Switch

Maximum drain voltage:

Maximum sink current:

25V
100 mA

Specifications
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Synchronized Performance

Number of synced units (PC-dependent):

Channel skew between any 2 units:

Setup constraints:

Count/Rate
Digital port assignment:

Internal pull-up value:

Input high voltage threshold:
Input low voltage threshold:
Terminal count:

Maximum rate frequency:
Minimum rate frequency:

Maximum count frequency:

Removable Memory
Type:

Required Format:

Number of Channels:

Indicators and Connections
Interface:

Indicator light:

USB A Connector (Drive):

Input connections:

Power

Power Consumption:

Environmental
Operating Temperature:
Operating Humidity:
Storage Temperature:

Storage Humidity:

16 units max; Throughput < 480 kHz
10 uS, typical
Syncs only with other model DI-2108-P instruments.

Same number of enabled channels per synced unit (type does not matter)

Same sample throughput rate per synced unit.

All units connected to the same USB controller using one or more hubs.

Count: Port 2 configured as input
Rate: Port 3 configured as input

4.7kQ

2.4V

0.8V

65,535

50 kHz (with total160 kHz burst rate)
0.5 Hz

50 kHz

MLC, pSLC, or SLC flash memory (with USB SD card reader); USB
thumb drive

FAT32

1; Unlock code required to record 2 or more channels to thumb drive

USB 2.0 (mini-B style connector)
Multi-color LED

USB drive for Stand-alone data logging
Cannot be used concurrently with the USB interface

Two 16-position screw terminal strips

<1.0 Watt, via USB interface

0°C to 50°C (32°F to 122°F)
0 to 90% non-condensing
-20°C to 60°C (-4°F to 140°F)

0 to 90% non-condensing

Specifications
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Physical Characteristics
Enclosure:
Mounting:

Dimensions:
Weight:

Software Support
WINDAQ software:

Programming:

Polycarbonate ABS, 0.080 inch thickness
Desktop; bulkhead

6.68D x 3.28W x 1.13H in.
(169.67D x 83.31W x 28.7H cm.)

5.7 oz. (162 grams)

OS support: Check online at http://www.dataq.com/products/windag/
windows-compatability/

Instrument Protocol, NET class

Specifications
5
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3. Installation

The following items are included with each DI-2108-P USB Data Acquisition System. Verify that you have the fol-
lowing:

* A DI-2108-P USB data acquisition instrument.
*  6-foot USB cable.
* A DATAQ Instruments screwdriver for signal lead connections.

* A 32GB USB flash drive with WinDaq software and an NIST-traceable calibration certificate (.pdf). This drive
can also be used for stand-alone data logging.

If an item is missing or damaged, call DATAQ Instruments at 330-668-1444. We will guide you through the appropri-
ate steps for replacing missing or damaged items. Save the original packing material in the unlikely event that your
unit must, for any reason, be sent back to DATAQ Instruments.

Install WINDAQ Software Suite

All software for the DI-2108-P can be installed via a download-able executable directly from the DATAQ Instru-
ments web site. The software is also available on the provided USB flash drive.

1. Disconnect all DATAQ Instruments USB devices from your Computer.

2. Remove the USB flash drive from your device and connect it to your computer’s USB port. Alternately down-
load software at run.datag.com.

3. Save the executable (Dataq Software Suite Web Setup.exe) to your local hard drive.

4. Double-click on the executable to extract the program and begin software installation.

Installation
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5. Follow the on-screen prompts and enter all required information.

6. Software installation is complete - you will now see a “Successful Installation” box - click OK to exit WINDAQ
Installation.

You can now plug the device(s) into your PC. Click on the “WinDaq Dashboard” shortcut to access WINDAQ soft-
ware and stand-alone setup.

Connect the Instrument to Your Computer

DI-2108-P instruments can be connected to your computer’s USB port using the provided USB cable. No external
power is required. Connect one end of the communications cable to the instrument port and the other to your PC’s
port. WinDaq Dashboard will recognize your device and appear in the device list.

Note: Use a powered USB hub or a USB port on your PC. Non-powered USB hubs may not have sufficient power to
run the instrument.

Installation
8
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4. Controls, Indicators, and
Connections

Digital Ports 0-6 +5V Out  Ground

\ 4 \ 44

Even Marker

USB Drive

Lo2s DO OOOOOOOOOOOOOO Push Button
Drive EEeOnt Rel:t);!)rd RE;%S ngn! b4 bs pe rovenp K
Model DI-2108-P Button

BiPATAQ
Bulkhead )@ @(Bmkhead
ar Rea_r-rned BL-J-SY Error mounti ng ear

Connecting | Idle | Recording | Armed
X)) -

mounting e — eciing | 1 =
[ Drive ce 100! eo | eo | ee | ee e | Sttus
USB CH1 CH2 CH3 CH4 CH5 CH6 CH7 CH8 St t LED
. oleloleloleloleloleloleloleloler s atus
Mini-B USB
Connection

A

Analog In Channels 1-8

Mini-B USB Connection

Use the supplied USB cable to connect and power the instrument through your computer’s USB port.

Screw Terminals

All input signal connections are made to the 16-port screw terminals. Each terminal is labeled on the instrument case.

A CAUTION A

Never touch exposed screw terminal connector pins or screws.
To avoid ESD damage in handling the device, take the following precautions:

Ground yourself with a grounding strap or by touching a grounded object before and during your handling of the
instrument.

Controls, Indicators, and Connections
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DI-2108-P Signal Connections

Refer to the following for screw terminal port identification.

Loz QOO OOOOOOOOOOOOO

: +5V GnD
Drive Event Record Rate Count

Model DI-2108-P
"EDATAQ®

INSTRUMENTS
www.datag.com

Connecting | Idle | Recording | Armed | Rearmed | Busy | Error
[ usB ce oe o0 - - )
| Drive o] ) @0 @0 [ J&) .. o0 o
USB CH1 CH2 CH3 CH5 CH6 CH7 CH8

Button

Status

OOOOOOOOOOOOOOOO A

CH#: Analog channels 1-8 (Programmable +2.5, +5, +10, 0-5, 0-10 Volts, +150V transient max.)

D#: Digital port (0-6). Can also be used for specific WINDAQ functions (+25 Vmax).

D0 Event — WINDAQ Remote Event Marker (or general-purpose)
D1 Record — WINDAQ Remote Start/Stop (or general-purpose)
D2 Rate — Rate Input (or general-purpose)

D3 Count — Counter Input (or general-purpose)

D4 and D5 — General-purpose digital ports

D6 Ext Trig — General-purpose for DI-2108-P

+5V: +4.75V out. Max current = 100mA.
GnD: Ground.

Connecting Signal Leads
Connect signal leads to the DI-2108-P:

1. Insert the stripped end of a signal lead into the desired terminal directly under the screw.

2. Tighten the pressure flap by rotating the screw clockwise with a small screwdriver. Make sure that the pressure
flap tightens only against the signal wire and not the wire insulation. Do not over-tighten.

3. Tug gently on the signal lead to ensure that it is firmly secured.

Loosen

Tighten
/Screw Terminal Block

% Signal Lead

Pressure Flap

Controls, Indicators, and Connections
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When an input signal is connected and WINDAQ Acquisition software is run, WINDAQ’s real time display immedi-
ately reveals the input waveform on your computer’s monitor.

Analog Inputs
Eight differential analog inputs measure +2.5, +5, £10, 0-5, 0-10 Volts (CH1 to CH8, programmable per channel).

Designed to withstand £150 V dc or peak ac.

400K
AN +(/)—\/\N‘—|_
+
AN - Q)_\/\N\J_
400K

Use the following diagram to connect Analog Input Channel 1.

(  EEEEEEEEEEEEELEI

2+ QO00000060000000

. D6 +5V GnD
Drive Event Record Rate Count "
Model DI-2108-P Button
'} DATAQ
INSTRUMENTS
() oo ()
Connecting | Idle | Recording | Armed | Rearmed | Busy | Error
[ usB oce o0 e - - - [
[ Drive 08 ool eo | eo | ee | ee| e | Status

USB CH1 CH2 CH3 CH4 CH5 CHé CH7 CH8

OOOOOOOOOOOOOOOQ A

M

\

a

Signal + S|gna| _

Controls, Indicators, and Connections
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Specify a full scale range for the channel in the menu item Edit > Channel Settings.

Gain

-F5 Yolt
-10.0000
-5.0000
-2.50000

+F5 Yolt
10.0000
5.0000

2.50000

—Acquisition Method -

* Awverage

" Last Point
 Maximum
 Minimum

 BMS

" Frequency

~Input Type

 Linear
€ Monlinear

" Thermocouple

[~ Unipolar

o |
Next |

[T Fahrenheit

Reset EU | Cancel

Previous |

+2.5, £5, and +£10 Volts are available. Select Unipolar for ranges of 0-5V or 0-10V.

Gain -FS Yolt +FS Volt —Acguisition Method -

1 .0000 10.0000

2 .00000 5.00000 9 fusriys

" Last Point
" Maximum
" Minimum
" BMS

" Frequency

~Input Type

* Linear
 Monlinear

" Thermocouple

[T Eahrenheit

Cancel

Reset EU |

Previous |

Scroll through all enabled channels with the Next and Previous buttons.

Controls, Indicators, and Connections
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Digital Ports

The DI-2108 contains 7 general-purpose digital ports. Each digital port can be configured as a digital input or used as a
switch to control an external load (up to 25 V and 100 mA). Many of the ports can also provide specific functionality in
WINDAQ or a third-party program.

DO Event is for WINDAQ Remote Events. This bit inserts an event marker in your data.

D1 Record is for WINDAQ Remote Storage. This bit can be programmed to begin recording data.
D2 Rate is for Rate measurements: 10Hz to 50kHz.

D3 Count is for Counter/Timer measurements up to 65,536.

D4 and DS are general-purpose digital inputs.

D6 Ext Trig is a general-purpose digital input on the DI-2108-P.

Equivalent Digital I/O Circuit:

3.3V +5
47K
Dig In Dx+
4.7K
Control Dx-
10Q

Controls, Indicators, and Connections
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WINDAQ Remote Events (DO Event)

To use a switch closure or TTL signal to record WINDAQ Event Markers, connect signal leads to the appropriate

Remote Control Event terminals on the DI-2108-P as shown below.

Signal + Signal -

vy

Lozsix DO OOOOOOOOOOOOOO
Drive E\E/)Sn! Re[t):jnrd Rg%e CEL?H( b4 ps D6 +5VGnD
Model DI-2108-P Button
“EDATAQ°
INSTRUMENTS
Connecting | Idle | Recording | Armed | Rearmed | Busy | Error
[one |6 601 66 oo | es eel e I Status
USB CH1 CH2 CH3 CH4 CH5 CH6  CH7  CH8
clelclelolelclelclelolelclololey e
Ao A

Once the switch closure or TTL signal is connected, activate Remote Events through WINDAQ Acquisition Software.
Events may be automatically placed on the rising or falling edge of the trigger signal. Use the menu command
Options > Remote Events + to set WINDAQ to place event markers on low-to-high transitions of the Event input.
Use the menu command Options > Remote Events - to set WINDAQ to place event markers on high-to-low transi-

tions of the Event input.

Event markers may also be placed in your data file manually by pressing the push button on the DI-2108-P Instru-
ment. You must enable Remote Events in WINDAQ to use the button (use the menu command Options > Remote

Events +or Options > Remote Events -).

l

A0 HOOOOOOOOOOOOOOO
Drive DO D1 D2 D3 D4 D5 Dé +5V GnD
Event Record Rate Count
Model DI-2108-P Button
‘EDATAQQ
INSTRUMENTS
O www.datag.com
[ Connecting | Idie | Recording | Armed | Rearmed | Busy | Error |
UsB | Oce |oe| ee | - | - - [ @ | Status
Dive | O® |@O0| @0 | @ [ e® [ee| @ |

USB CH1  CH2 CH3 CH4 CHs CH6 CH7  CHs

0

OOOO0OO0OOOOOOOOOO A

'f

Controls, Indicators, and Connections
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An example event marker in a WINDAQ data file is shown below.

Event Marker*

& WINDAQ - Hydr.. “tic Actuator Qualification.wdq
File Edit View Search
1000.0

g Transform XY Options Help

psig | P :

288l

-3.136 ;i o : i G i i i i LVDT Feedback | |
2=3  Volt {7 I T P T S R R T

i S B S

_9153 o et M R L e S b VR i S S B e o TR
IEASE 79.3680 SEC({TBF) .0816 SEC({TH} 62.4 %EOF T: .0080 SEC-DIV
4 »

*Please Note: Event Markers do not display in the real-time WINDAQ acquisition software - they only display in the
WINDAQ playback software (WWB).

Controls, Indicators, and Connections
15
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WINDAQ Remote Storage (D1 Record)

To use a switch closure or TTL signal to begin recording data remotely, connect signal leads to the appropriate
Remote Control Record terminals on the DI-2108-P as shown below.

Signal + Signal -

2

D6  +5V GnD

2--00000000000000Q0

Drive Event Record Rate Count

Model DI-2108-P Button

BiPATAQ
)

www.datag.com

‘ Connecting | Idle | Recording | Armed | Rearmed | Busy | Error

UsB oce oe [X] - - - [
[owe | 0@ 00| ®0 | @6 | ee |ee| e | Sttus
USB CH1 CH2 CH3 CH4 CH5 CH6 CH7 CH8

OOOOOOOOOOOOOOOQ A

Once the switch closure or TTL signal is connected, activate Remote Storage (Record) through WINDAQ Acquisition
Software. Storage to Disk may be automatically placed on the rising or falling edge of the trigger signal. Use the
menu command Options > Remote Storage 1 to set WINDAQ to begin recording on low-to-high transitions of the
Record input. Use the menu command Options > Remote Storage 0 to set WINDAQ to begin recording on high-to-
low transitions of the Record input.

WINDAQ Rate (D2 Rate)

Enable channel 10 to record Rate, or the number of falling-edge transitions per unit of time, that are applied to this
input. Click on Edit > Channels in the WINDAQ Acquisition menu to open the Channel Selection grid. Channel 10 is

Controls, Indicators, and Connections
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the designated Rate channel. Click on the Channel 10 channel box to enable/disable Rates. The Channel 10 channel

box will display an “R” when enabled.

Channels:

4DSE903E

A
E:
Z:
D
E:
F.
[EN
H:
J:
K.
L:
.
H:
F.
o

Click or press Space to =select (check) or deselect.
Click or press I in column 9 to select digital input.
Click or press R in column 10 to =select rate counter.
Click or press C in column 11 to =elect reset counter.

0K Cancel

Connect any TTL pulse stream (25 VDC max) to the D2 Rate channel on the DI-2108-P.

Signal + Signal -

vy

Lozsnax DO OOOOOOOOOOOOOO
Drive E\E/)Snt Re[t):jnrd RDa%e CEL?"( b4 ps D6 +5VGnD
Model DI-2108-P Button
ﬁDATAQQ
INSTRUMENTS
www.datag.com
Connecting | Idle | Recording | Armed | Rearmed | Busy | Error
UsB oe [X] - - - [
} ove | 08 00| @0 | €6 | ee | ee e | Sw@tus
USB CH1  CH2 CH3 CH4 CH5 CH6  CH7  CH8
OOOOOOOOOOOOEOO®E A
- A

. EIIIITIITITTE

Select Channel 10 in the channel display, then select Edit > Channel Settings in the menu to specify a full scale

range for the Rate channel. Ranges of 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, 10000, 20000, and 50000 Hz are
available. Choose a range that comes closest to your expected full scale rate or frequency. For example, if you need to
measure the output of a flow meter that can measure a maximum flow rate of 100 gallons per minute, and the output

Controls, Indicators, and Connections
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frequency at that rate is 100 Hz, you would choose the 100 Hz range setting. A range setting of 200 Hz full scale sac-
rifices half of the instrument's resolution at 200 gallons per minute, and a range of 50 Hz allows measurements to
only 50 gallons per minute full scale.

Gain -FS Hz +F5 Hz —hAcguisition Method -

R0000.0
20000.0
10000.0 * Last Point
R000.0
2000.0 " Maximum

1000.0 o
500.0 = Minimum

" Average

50.0  Frequency
20.0

10.0

—Input Type

& Linear
Filter Length = |1 " Nonlinear

" Thermocouple

™ Unipolar [~ Cycles!min

1].4 Reset EL Cancel

Previous

Check the "Cycles/min" box to display and select frequencies reported in cycles per minute instead of cycles per sec-
ond (the measurement interval remains the same). Tachometer measurements in units of RPM (revolutions per min-
ute) is just one example that benefits from selecting this option. For example, if the 100 Hz range setting is selected
and "Cycles/min" is checked, the full scale range is actually 6000 cycles per minute.

Please Note: To measure the maximum rate, which is defined as 2 times the Maximum Sample Rate/Channel , the cur-
rent values of Maximum Sample Rate/Channel divided by Sample Rate per Channel MUST be an integer.

WINDAQ Counter (D3 Count)
Enable channel 11 to record Counts, or the number of falling-edge transitions that are applied to this input. The count
may be reset via WINDAQ software or under program control as necessary. Click on Edit > Channels in the WINDAQ

Controls, Indicators, and Connections
18



DI-2108-P Hardware Manual

Acquisition menu to open the Channel Selection grid. Channel 11 is the designated Count channel. Click on the
Channel 11 channel box to enable/disable Counts. The Channel 11 channel box will display a “C” when enabled.

Channels:
4D5SBY03E

A
B:
c:
I
E:
F
G
H:
J:
K.
L.
M.
"
P
Q:

Click or press Space to =elect (check) or deselect.
Click or press I in column 9 to select digital input.
Click or press B in column 10 to =elect rate counter.
Click or press C in column 11 to select reset counter.

0K Cancel

The counter channel accumulates counts over time whether recording or in standby mode as soon as the Counter
channel is enabled. The accumulated values will be recorded to your data file unless you reset the counts to zero. The
maximum count value is 65,535 before the counter resets to zero automatically.

Use the Edit > Reset Count command in WINDAQ Acquisition software to reset counts immediately to zero. This
feature is available in both standby and record modes.

Use the Edit > Preferences > Reset Count on New File Record in WINDAQ Acquisition software to reset the count at
the start of a new file or when using the Edit > Preferences > Record Next File on Full or Open Next File on Full fea-
ture to reset counts to zero every time a new file is started.

Use the Edit > Preferences > Reset Count on Manual Record in WINDAQ Acquisition software to reset counts to
zero every time you begin or resume recording a data file using the File > Record command (F4).

Controls, Indicators, and Connections
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Connect any TTL pulse stream (25 VDC max) to the D3 Count channel on the DI-2108-P.

Signal + Signal -

vl

2--Q000000060000009

D6  +5V GnD

J

Drive Rate

Model DI-2108-P

Event Record Count

Button

usB

DATAQ
ﬁ INSTRUMENTS
www.datag.com
Connecting | Idle | Recording | Armed | Rearmed | Busy | Error
[ usB oce 00| ee - - - [
| Drive ce @0 [X°) [ 16} [ 1) o0 | o

CH1 CH2

OOOOOOOOOOOOOOOQ A

CH3

CH4

CH5

CHe

CH7

CH8

Status

Ao

N

N o © o ccooosscoosss NINNND

General Purpose Digital Inputs

Enable Channel 9 for general-purpose digital input functions. Click on Edit > Channels in the WINDAQ Acquisition
menu to open the Channel Selection grid. Channel 9 is the designated Digital Input channel. Click on the Channel 9
channel box to enable/disable the digital inputs. The Channel 9 channel box will display an “I” when enabled.

Channels:
ADSBY03E

A
E:
C:
L
E:
F:
G
H:
J:
K-
L:
M:
H:
F:
Q:

CZlick or press Space to =select (check) or deselect.
Click or pres= I in column 9 to =select digital input.
Click or press R in column 10 to =elect rate counter.
Click or pres= C in column 11 to =elect re=et counter.

0K Cancel
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Channel 9 records and displays all the digital inputs, even the state of the Rate and Count inputs if those channels are
enabled. With Channel 9 selected in the display window click Scaling > Digital Plot to show a digital display and
make the data more meaningful on-screen using WinDaq.

General Purpose Digital Outputs

Take care when configuring the load to be switched to ensure that the digital port is not damaged:

Controls, Indicators, and Connections
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4-20mA Current Loop Measurements

Use the following diagram for 4-20mA current loop measurement connections.

(  EEEEEEEEEEEEEEEI

Loz DO OOOOOOOOOOOOOO
Drive Evont Record Fae  Count O bs D6 +8VGnD
Model DI-2108-P Button
BIDATAQ
INSTRUMENT:
Connecting | Idle | Recording | Armed | Rearmed | Busy | Error
e | Ce 1601 66 65 | ee el e | Sl
uUsB CH1 CH2 CH3 CH4 CH5 CH6 CH7 CH8
OOOOOOOOOOOOOOOQE A
- A

The shunt resistor should

Current Loop

T

Shunt Resistor

Model R250

4-20 mA
current source

be placed on the low side of the circuit as shown below:

L Loop Power
Supply

e

ransmitter

2500
Shunt Resistor

+ -
v v
To DI-2108-P
Analog Input Channel
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Set the engineering units as desired and define upper/lower levels in WINDAQ as 1V = 4mA for the low value and 5V
= 20mA for the high value. For example, when using WINDAQ Acquisition software, in the EU Settings dialog box:

Channel 1 Engineering Unit Settings

Upper Level ﬁ 5
Lower Level ﬁ K

Previous ‘

EU EU Tag
= |20
mb
=] |4
Mext ‘ Set Dﬁset‘ Cancel ‘

Enter the following values:

Volt | EU EU Tag
Upper Level 5 20
Lower Level 1 4

Visit our website at http://www.dataq.com/blog/data-acquisition/4-20-ma-current-loop-measurements/ to address all
popular 4-20mA configurations.

You can also associate these values to a physical measurement such as pressure, load, flow, torque, etc. Read the Help
files for more information regarding Engineering Units Settings.

LED Status Indicator

The DI-2108-P provides a multicolor LED for instrument status and notification. Use the table below for a detailed
description of each available state.

State Mode Description
Connecting The device is looking for a connection to your PC or USB thumb
O . drive. It will check the USB interface first, then the USB thumb drive.
Once a connection is established the device will enter Idle mode.
Blinking White
O . Idle The device is connected to and communicating with your PC through
USB Connected L}iz USB port. The USB thumb drive and Ethernet port are not accessi-
Blinking Green
O O Idle The device is in Stand-alone mode. The USB interface is not accessi-
USB Drive Con- ble.
Blinking Green/ nected
Yellow
. . Acquiring Data WinDaq Acquisition Software is running and the device is acquiring
to PC via USB data to your PC via the USB interface.
Blinking Blue Interface

Controls, Indicators, and Connections
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. O Recording Data The device is acquiring data and recording to your USB thumb drive.
to USB thumb Do 1.10t remove power - power interruption could result in data file cor-
o Dri ruption.
Blinking Blue/ rve
Green
Armed The device is acquiring data and waiting for a trigger condition to
. ( ) . begin recording to your USB thumb drive. Do not remove power or
USB t humb DHV? the USB thumb drive - either could result in data file corruption.
Blinking Blue/ is waiting for a trig-
Cyan ger condition
Re-armed The device is acquiring data and waiting for another trigger condition
. . . to continue recording to your USB thumb drive. Do not remove power
USB t humb DI‘IVE.t or the USB thumb drive - either could result in data file corruption.
Blinking Blue/ is waiting for a trig-
Cyan ger condition
Busy The device is reading from or writing to the USB thumb drive. Do not
. . USB thumb Drive remove power or the USB thumb drive - either could result in data file
. corruption.
Blinking Red | 1 busy
Error The device is unable to perform any operations. Use the control button
. or cycle power to resolve the error.
Solid Red
O Button Pushed The LED turns white to indicate the control button is engaged.
Solid White
Idle The device is connected to and communicating with your PC through
O . USB connected in the USB port in CDC mode. WinDagq software will not run. The USB
CDC mod thumb drive and Ethernet port are not accessible.
Blinking Yellow mode

USB Drive Port

Allows you to record to any USB flash memory device. Not all flash memory is fast enough to record at higher sam-
ple rates. Use the provided USB flash drive for rates below 20,000 S/s Throughput. Please Note: The mini-USB

interface cannot be used in conjunction with the USB Drive. You MUST disconnect the device from the computer to
record to the USB thumb drive.

Control Button

The Control Button can be used to stop or start recording data to your memory card (SD) when using the instrument
as a stand-alone data logger. The Control Button can also be used to reconfigure the instrument to factory default set-
tings and to re-format memory card files left open due to power failure or other circumstance. The Control Button is
inoperable while running WINDAQ Acquisition software.

Record Data to USB Thumb Drive

Record data to an installed USB thumb drive. The device must be in Idle mode and set for USB Drive (mode LED
must be flashing Green/Yellow). After the button is pressed, the mode LED will flash Blue/Green or Blue/Cyan to
indicate it is in a recording mode.
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Stop Recording to USB Thumb Drive

Manually stop recording to the USB thumb drive (when the mode LED is flashing Blue/Green, Blue/Cyan, or Blue/
Magenta). After the button is pressed the mode LED witll flash Green/Yellow to indicate Idle.

Fix Errors

The Control Button can also be used to fix some common operating errors. When the instrument is in Error mode
(mode LED is solid red), some action must be taken to fix the error before you can use it. Generally, the Control But-
ton can be used to make the instrument operational again when in Error mode.

Switching between LibUSB and CDC Modes

The native communication mode of the DI-2108-P is LibUSB but it can be switched to the USB CDC
(Communication Device Class). CDC mode allows the USB port of DI-2108-P devices to appear like a traditional
RS-232 port, which is common across most operating systems and development languages. Please note: LibUSB
communication is required for WinDaq Acquisition software and programming with our NET SDK. Only switch to
CDC mode when writing your own programs at the protocol level (for example, Python applications). Use the
following sequence to switch your device to/from LibUSB/CDC modes:

1. Connect the device to your PC via the USB port.
2. Apply power to the device.

3. When mode LED stops blinking white and is in Idle mode, push and hold the Control button. This must be com-
pleted within five seconds after the device is in Idle mode.

4.  When the mode LED turns red, release the Control button.
5. The Mode LED will flash white then indicate Idle in either LibUSB or CDC mode:
*  CDC mode: Blinking Yellow

* LibUSB mode: Blinking Green

Save Stand-alone configuration to Thumb Drive

Save stand-alone configuration settings using the Control Button. Stand-alone configurations can also be saved to the
thumb drive via the Dashboard (preferred method). Device must be in Idle mode for USB thumb Drive (mode LED
blinks green/yellow). The Unlock Code must be purchased for your device in order to save the stand-alone
configuration.

1. Format your USB thumb drive using your PC.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.

4. Plug the formatted (empty) thumb drive into the device (Drive) while holding the button in.
5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the thumb drive and revert to Idle mode when complete.

Configuration files include config.whd or config.whe. Use the WinDaq Dashboard to create configuration files.

Controls, Indicators, and Connections
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Apply Stand-alone Configuration to Device

Load stand-alone configuration settings using the Control Button. Stand-alone configurations can also be applied via
the Dashboard (preferred method). Device must be in Idle mode for USB thumb Drive (mode LED blinks green/
yellow). The Unlock Code must be purchased for your device in order to apply the stand-alone configuration.

1. Save configuration files to your USB thumb drive.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).
3. Push and hold the Control button.

4. Plug the thumb drive into the device (Drive) while holding the button in.

5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the device and revert to Idle mode when complete.

Configuration files include config.whd or config.whe. Use the WinDaq Dashboard to create configuration files.

WinDaq Dashboard

The WinDaq Dashboard allows you to run WinDaq Data Acquisition software, sync the device clock with your PC,
and configure your instrument for stand-alone data logging to record data to a USB flash drive.

Configure  Help

Model Serial Number Status

Mon-Channelstretch™ Devices
[ ] 012108 SCBEDS2D Available

Controls, Indicators, and Connections
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Use the Configure menu to access the Stand alone setup window.

File
Analog Channel Setup Digital Channel Setup

M CH1 | Configue | [] CHS (Discrete)

[JcH2 | Corfigure [JCHI0(Rate) | 10000Hz v

[]cH3 | Corfigure L] CH11 (Court)
[]cH4

[]cHs

[]cHs

[ ] cH7

[]cHs
File Storage Mode Sampling Interval
(") Triggered mode

) Circular mode
(@) Mon circular mode Selectable Range 6.25 psto 1000 s

] Timed Storage

1[ms | 200 ssesh

File Storage Format

(@) WinDaq format ] Record on Power Startup
) C5V format

Select and configure all channels available on your device, select a sampling interval, and setup recording Trigger
conditions. The Stand alone configuration also allows you to Save/Load configurations via the File menu. Use the
help file provided in WinDaq Dashboard to learn more.

ChannelStretch™

Connect up to 16 DI-2108-P devices with a powered USB hub (or multiple cascaded/connected powered USB hubs)
to record more than 8 channels of data to a single WinDagq file. This provides a total of up to 128 analog channels and
112 digital ports at a maximum throughput rate of 480 kHz. Cascade multiple USB hubs to expand port count.
Synchronized instruments must have the same sample rate and have the same number of enabled channels
independent of channel type or gain factor. The WinDag/Unlock option per instrument is required to synchronize
two or more DI-2108-P devices when using WinDaq software.

Controls, Indicators, and Connections
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Connection

All device must be on the same USB hub or controller* in order to synchronize data acquisition.

ChannelStretch™ Technology

to PC usB

16 units max
Max throughput = 480 kHz

to Power
as required

*DATAQ Instruments 7-port USB hub (part number 2000310). Cascade for a higher port count.

*Please Note: Because of the way Windows operating systems manage USB controllers, the only way to be absolutely
sure you are on the same controller is to use a powered USB hub.
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Channel Selection

Devices are listed in the Channel Selection grid in alpha-numeric order of the serial numbers of the device. Devices
must be connected to the USB hub before starting WinDag.

Channels:
4D5B9038

4DER903E A:

B:
c:
I
E:
F
G
H:
J:
K.
L.
M.
"
P
Q:

Click or press Space to =elect (check) or deselect.
Click or press I in column 9 to select digital input.
Click or press B in column 10 to =elect rate counter.
Click or press C in column 11 to select reset counter.

Cancel |

Enable the same number of channels in each device you would like to record data from.

Channels:
4D5B9038

4DEB903E A:

CcmMmEEH=m oD omm oo m

CZlick or press Space to =select (check) or deselect.
Click or pres= I in column 9 to =select digital input.
Click or press R in column 10 to =elect rate counter.
Click or pres= C in column 11 to =elect re=et counter.

Cancel |
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Sample Rate

The sample rate for DI-2108-P devices is set as a per device throughput rate or “Sample Rate/Device.” Select Edit >
Sample Rate in the main menu or press F3.

Owversampling Factor = 400

Burst Rate/Device = 160000

Sample Rate/Device = 400

1] .4 Cancel

The sample rate per channel is displayed in the lower left corner of the WinDaq screen at S/s/CHAN: (samples per
second per channel).

4=4 Wolt

=10, 0000 bbb iy
So=-CHAH: 100 zec-DIV: 0.2 Status: SET-TF

Total throughput rate is displayed in the top-left portion of the WinDaq screen at S/s (F3). For example, if two devices
are connected and the Sample Rate/Device is 400, S/s would be 800.

Eile Edit View Scaling Optiocns Help

Mode: O=cill Channel=s: 8
S<= (F3): 800 Compressi(F71: 1 Storage: % us=ed
T0.0000 Pl [ T oo b o b b T ]
—.oon3 :
WAt \
total throughput rate (all devices)
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5. Unlock WinDaq or Stand-
alone Operation

The DI-2108-P will record up to four channels using WinDag/Lite software and a single channel to the USB thumb
drive. An unlock code is required to record more than 4 channels using WinDaq software or to the USB thumb drive.
There are two unlock codes available for the DI-2108-P. Go to https://www.dataq.com/products/di-2108/ to purchase
the unlock codes (go to Accessories) or call 330-668-1444. Once purchased, you will be given a Key code to enter
into WinDaq or the WinDaq Dashboard. Please Note: Devices ordered with an Unlock Code will already be unlocked
and do not require this procedure.

WinDag/Unlock

Allows you to record more than four channels using WinDaq Software including multiple units using ChannelStretch.
1. Start WinDaq Acquisition software.

2. Click the menu item Help > Unlock WinDagq.

To purchase WinDagfUnlock software, go to www.datag.com
or call DATAQ Instruments at 330-668-1444.

Serial #=  ADSB903E
Key = | | ! |

oK | Help | Cancell

3. Enter the Key in the appropriate dialog boxes.

4. Click OK.

SA-Enabled

Allows you to unlock all channels for stand-alone data logging as well as all the channels in WinDaq.

1. Start WinDaq Dashboard software.

Unlock WinDaq
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2. Select your device and click the menu item Configure > Stand Alone Setup.
Stand-alone operation using all channels has not been enabled on this device.
Please purchase and apply an unlock code to fully enable this feature. You can
recard a single channel without the unlock code, Would you like to enter the
code now?
3.

Click on the Yes button to enter your code. Click on the No button to go to Stand-alone configuration for a single
channel.

Purchase the code to unlock Stand-slone operation (part number

SA-Enabled) at www datag.com or call Datag Instruments at
330-668-1444,

Serial #= HCBEDS2D

4. Enter the Key in the appropriate dialog boxes.

Click OK.

Unlock WinDaq
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6. Dimensional Drawing
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